re = /(?im)^([a-z]+).*(\r?\n[^a-z].*)*/
str = 'Acanthite (Y: 1855) 02.BA.35 [18] [19] [20]
(IUPAC: Disilver sulfide)
Acetamide (1974-039) 10.AA.20 [21] [22] [23]
(IUPAC: Acetic acid amide)
Achalaite (2013-103) 04.?? [24] [no] [no]
Achavalite (Y: 1939'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result