#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Pattern\[\d+\]:[^P]*(?:P(?!attern\[\d+\]).)*"
Local $sString = "Pattern[1]: " & @CRLF & _
"Key : "key1" " & @CRLF & _
"Value : 100" & @CRLF & _
"Pattern[2]: " & @CRLF & _
"Key : "key2" " & @CRLF & _
"Value : 20" & @CRLF & _
"Pattern[3]: " & @CRLF & _
"Key : "key3" " & @CRLF & _
"Value : 30" & @CRLF & _
"Pattern[4]: " & @CRLF & _
"Key : "key4" " & @CRLF & _
"Value : 220"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")