using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Pattern\[\d+\]:[^P]*(?:P(?!attern\[\d+\]).)*";
string input = @"Pattern[1]:
Key : ""key1""
Value : 100
Pattern[2]:
Key : ""key2""
Value : 20
Pattern[3]:
Key : ""key3""
Value : 30
Pattern[4]:
Key : ""key4""
Value : 220";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}