package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^()]+?)\)`)
var str = `43.3433443 25.3434334), (43.32424432 25.435345345, 43.21313123, 25.32432423423), (43.123123123 25.344234234, 43.1234123123 25.23213123))
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}