re = /([^()]+?)\)/
str = '43.3433443 25.3434334), (43.32424432 25.435345345, 43.21313123, 25.32432423423), (43.123123123 25.344234234, 43.1234123123 25.23213123))
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end