const regex = /^([A-Za-z ]+)\s*\|\s*([A-Za-z ]+)\s*\|\s*(\d+)$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([A-Za-z ]+)\\s*\\|\\s*([A-Za-z ]+)\\s*\\|\\s*(\\d+)$', 'mg')
const str = `Paduch | Karol | 21
Young | Travis | 25
Martin | Chris | 21
Zander Fanden | Buttfuck | 23`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}