import re
regex = re.compile(r"^([A-Za-z ]+)\s*\|\s*([A-Za-z ]+)\s*\|\s*(\d+)$", flags=re.MULTILINE)
test_str = ("Paduch | Karol | 21\n"
"Young | Travis | 25\n"
"Martin | Chris | 21\n"
"Zander Fanden | Buttfuck | 23")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")