using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^= ]+)=""(.*?)""\s+(?=([^= ]+=|\/>))";
string input = @"<order acode=""7102774"" ProductName=""Какой-то текст ""с скобочками"", которые нужно заменть"" ClientBarCode="" />";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}