$re = '/([^= ]+)="(.*?)"\s+(?=([^= ]+=|\/>))/';
$str = '<order acode="7102774" ProductName="Какой-то текст "с скобочками", которые нужно заменть" ClientBarCode="" />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);