import re
regex = re.compile(r"(?:^(?:(\d+)')?(?:[-| ]*)(?:(\d*(?: ?\d+\/\d+)?|(?:\d*\.\d+)?)?\")?$)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("5'-2 1/2\"\n"
"5' -2 1/2\"\n"
"5' 4 2/3\"\n"
"5'-4\"\n"
"5'3 1/4\"\n"
"4\"\n"
"1/8\"\n"
"5'-3.25\"\n"
"5' 3.25\"\n"
"5'3.25\"\n"
"3.25\"\n"
".25\"\n"
"345'-12.318\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")