import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:0,)+|(?:,0)+$|\\b0,";
final String string = "66500,0,0,0,0,0,0,0,0,0,10000,0,0,0,0,0,0,0\n\n"
+ "0,0,0,0,0,0,0,0,750,0,0,0,0,0,0,0,0,0,0\n"
+ "123,0,0,750,0,0,0,0,0,0,0,0,0,0,3455\n\n"
+ "0,0,0,456\n"
+ "234,0,0,0,456\n"
+ "23,0,466\n"
+ "34,4567,4556,0,0,0,0\n"
+ "0,0,0,0,34,4567,4556";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}