// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:0,)+|(?:,0)+$|\b0,").unwrap();
let string = "66500,0,0,0,0,0,0,0,0,0,10000,0,0,0,0,0,0,0
0,0,0,0,0,0,0,0,750,0,0,0,0,0,0,0,0,0,0
123,0,0,750,0,0,0,0,0,0,0,0,0,0,3455
0,0,0,456
234,0,0,0,456
23,0,466
34,4567,4556,0,0,0,0
0,0,0,0,34,4567,4556";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}