re = /(?=.*(\\\*\*|\*\\\*)).*/m
str = '**
\\**
case**
case\\**
*\\*'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result