package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?:[^\\|]+|\\\|?)+)`)
var str = `fielda|field \b |field\|wi\th\|pipe\|inside`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}