re = /((?:[^\\|]+|\\\|?)+)/
str = 'fielda|field \\b |field\\|wi\\th\\|pipe\\|inside'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end