package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?P<w>(?:[^\\|]+|\\\|?)+)`)
var str = `word1| word 2 |word\|3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}