$re = '/(?P<w>(?:[^\\\\|]+|\\\\\|?)+)/';
$str = 'word1| word 2 |word\\|3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);