$re = '/( )(?=[^"]*"(?:[^"]*"[^"]*")*[^"]*$)|( )(?=[^(]*\))/m';
$str = 'abcd(efg h i)jkl
abc def(dfdsff fd)dfdsf
abc def"dfdsff fd"dfdsf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);