re = /( )(?=[^"]*"(?:[^"]*"[^"]*")*[^"]*$)|( )(?=[^(]*\))/m
str = 'abcd(efg h i)jkl
abc def(dfdsff fd)dfdsf
abc def"dfdsff fd"dfdsf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end