$re = '/.*(_ew1_\d+_rt)$/m';
$str = 'filename_ew1_234_rt
filename_ew1_456_rt
filename_ew1_78946464_rt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);