re = /.*(_ew1_\d+_rt)$/m
str = 'filename_ew1_234_rt
filename_ew1_456_rt
filename_ew1_78946464_rt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end