$re = '/((?:\+27|27|0)(?:\d{9}))/';
$str = '+27832227765, 27838776654 or 0612323434.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);