re = /((?:\+27|27|0)(?:\d{9}))/
str = '+27832227765, 27838776654 or 0612323434.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end