// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.*),(.*),(.*),(.*)").unwrap();
let string = ",UBS154754528,A121215441,10
,UBS154754528,A121215442,20
,UBS154754528,A121215443,15
GFdfgdfD45454dfgd5457,UBS154754528,A121215444,25
AAA454545455,UBS154754528,A121215445,254
vvGFD454545457,UBS154754528,A121215446,215
dad454545457,UBS154754528,A121215447,55
eww454545457,UBS154754528,A121215448,214
asd454545457,UBS154754528,A121215449,26
trtr454545457,UBS154754528,A121215450,25
,UBS154754528,A121215451,251
,UBS154754528,A121215452,252
,UBS154754528,A121215453,23
,UBS154754528,A121215454,251
gdfgd454545457,UBS154754528,A121215455,251
dfdf454545457,UBS154754528,A121215456,25
fgdfgd454545457,UBS154754528,A121215457,95
gdfgFD45dfg4545457,UBS154754528,A121215458,58
dfgdf4545fg45457,UBS154754528,A121215459,254
dfgd45454dfgfd5457,UBS154754528,A121215460,25
dfdfGFD45dfgdf4545457,UBS154754528,A121215461,254
,UBS154754528,A121215462,66
,UBS154754528,A121215463,22
,UBS154754528,A121215464,54
GfdfgD454fd545457,UBS154754528,A121215465,24
GFfdgD454dfg545457,UBS154754528,A121215466,45
GFfdgD45454fgd5457,UBS154754528,A121215467,11
fgfD4545dfg45457,UBS154754528,A121215468,255
GFfdgD454dfgd545457,UBS154754528,A121215469,88
";
let substitution = "insert into test_table values('$1','$2','$3',$4);";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}