import re
regex = re.compile(r"<script.*?src=\"(.*?)\"")
test_str = "<script type=\"text/javascript\" src=\"http://chrismills.la/test.js\"></script>"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")