using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?![ ])(?!.*[ ]$)(?!.*[ '-]{2})[a-zA-Z0-9 '-]*$";
string input = @"9 words
two words
two words
two words ending with space
double spaces";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}