$re = '/^(?![ ])(?!.*[ ]$)(?!.*[ \'-]{2})[a-zA-Z0-9 \'-]*$/m';
$str = '9 words
two words
two words
two words ending with space
double spaces';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);