#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(http|https)(:\/\/SashaGoddess\.com\/)(.*?\/)(.*?\/)(.*?\/)"
Local $sString = "http://SashaGoddess.com/catalog/razdel/element/" & @CRLF & _
"" & @CRLF & _
"https://SashaGoddess.com/Dream/Miracle/Destiny/"
Local $sSubst = "$1$2$4$5"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)