$re = '/(http|https)(:\/\/SashaGoddess\.com\/)(.*?\/)(.*?\/)(.*?\/)/';
$str = 'http://SashaGoddess.com/catalog/razdel/element/
https://SashaGoddess.com/Dream/Miracle/Destiny/';
$subst = "$1$2$4$5";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;