using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^a;[^;\r\n]+;\K[^;\r\n]+$";
string input = @"a;b;c
a;x;23
b;b;12";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}