$re = '/^a;[^;\r\n]+;\K[^;\r\n]+$/m';
$str = 'a;b;c
a;x;23
b;b;12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);