const regex = /^(?<lastName>[^\s]+)([\s](?<firstName>.+))?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<lastName>[^\\s]+)([\\s](?<firstName>.+))?$', '')
const str = `A B, A B C D E`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}