$re = '/^(?<lastName>[^\s]+)([\s](?<firstName>.+))?$/';
$str = 'A B, A B C D E';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);