#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+(?:,\d+)*,?$"
Local $sString = "1" & @CRLF & _
"1,2,3,5" & @CRLF & _
"1,23" & @CRLF & _
"1|46|6778|567" & @CRLF & _
"1,278,3780,50" & @CRLF & _
" 57,,,,,,578678,678,67,678,678,,,,,6,78,6"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")