using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+(?:,\d+)*,?$";
string input = @"1
1,2,3,5
1,23
1|46|6778|567
1,278,3780,50
57,,,,,,578678,678,67,678,678,,,,,6,78,6";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}