package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^category_(.*)\/?$`)
var str = `category_namecategory
category_namecategory_numberpage`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}