re = /^category_(.*)\/?$/m
str = 'category_namecategory
category_namecategory_numberpage'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end