using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^category_([a-zA-Z]{4,20})$";
string input = @"category_namecategory
category_namecategory_numberpage";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}