$re = '/^category_([a-zA-Z]{4,20})$/m';
$str = 'category_namecategory
category_namecategory_numberpage';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);