package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`/szukaj/?([a-zA-Z0-9-]+)?`)
var str = `/szukaj/miło`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}