$re = '//szukaj/?([a-zA-Z0-9-]+)?/';
$str = '/szukaj/miło';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);