using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(www.?)*example.com";
string input = @"example.com -> www.example.net
www.example.com -> www.example.net
something.example.com
www
wwwexample.com
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}