re = /(www.?)*example.com/m
str = 'example.com -> www.example.net
www.example.com -> www.example.net
something.example.com
www
wwwexample.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end