const regex = /<td>.*?(?:мука: (\d+))?.*?(?:дрожжи: (\d+))?.*?(?:яйцо: (\d+))?.*?(?:сыр: (\d+))?.*?(?:мясо говяжье: (\d+))?.*?(?:мясо свиное: (\d+))?.*?(?:рыба: (\d+))?.*?(?:лук: (\d+))?.*?(?:соль: (\d+))?.*?(?:перец: (\d+))?.*?ккал: (\d+).*?углеводы: (\d+).*?жирность: (\d+).*?/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<td>.*?(?:мука: (\\d+))?.*?(?:дрожжи: (\\d+))?.*?(?:яйцо: (\\d+))?.*?(?:сыр: (\\d+))?.*?(?:мясо говяжье: (\\d+))?.*?(?:мясо свиное: (\\d+))?.*?(?:рыба: (\\d+))?.*?(?:лук: (\\d+))?.*?(?:соль: (\\d+))?.*?(?:перец: (\\d+))?.*?ккал: (\\d+).*?углеводы: (\\d+).*?жирность: (\\d+).*?', 'i')
const str = `<div id=""><table width=300 cellpadding=2 cellspacing=0><tr><th style=text-align:center;>Название</th></tr>Бtr><td>мука: 40% <br />яйцо: 50% <br />соль: 10% <br /></td></tr><tr><th style=text-align:center;></th></tr><tr><td><hr />ккал: 100 <br /></td><td><hr />углеводы: 100 <br /></td><td><hr />жирность: 100 <br /></td></tr></table></div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}