package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`/([\w_.-]+[.](jpg|gif|png))`)
var str = `020_1473651603.png`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}