$re = '//([\w_.-]+[.](jpg|gif|png))/';
$str = '020_1473651603.png';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);