package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\w\d\s]+:\s*`)
var str = `Category:
Wiki Category:
Some tag:
Coool 11 number tag:
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}