re = /^[\w\d\s]+:\s*/m
str = 'Category:
Wiki Category:
Some tag:
Coool 11 number tag:
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end