$re = '/to (\w+)/';
$str = 'to be to see to read';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);