$re = '/^[0-9]{1,6}X{0,6}$/m';
$str = '123456
123XXX
1XXXXXX
123XXXXXXX';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);